package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(abc)|(def))(?1)`)
var str = `abcabc
defabc
abcabc
defdef`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}