package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^[\p{Zs}\t]*\d+`)
var str = `1 Na na
2 Blah blah
No.
2345 yes...`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}