const regex = /\s?([:[\()=$~|^$*,>+~]) ?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?([:[\\()=$~|^$*,>+~]) ?', 'g')
const str = `.class #id div, p div div > p [attribute \$= value] a
: visited input:disabled p: nth-last-of-type( 2)
p [attribute]
p[attribute=value ]
div a [ attribute~=value ]
[attribute| =value]
[attribute^=value]
[attribute \$=value]
[attribute*=value] `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);