// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s?([:[\()=$~|^$*,>+~]) ?").unwrap();
let string = ".class #id div, p div div > p [attribute $= value] a
: visited input:disabled p: nth-last-of-type( 2)
p [attribute]
p[attribute=value ]
div a [ attribute~=value ]
[attribute| =value]
[attribute^=value]
[attribute $=value]
[attribute*=value] ";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}