import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^20([0-2][0-9])(\\.(0[1-9]|1[012])(\\.(0[1-9]|1[0-9]|2[0-9]|3[01]))?)?_([a-z]{1,24}((\\-)?[a-z]{1,16})?)((\\.[a-z]{1})|(\\.[a-z]{1,16}\\.[a-z]{1}))?_(([a-z]{1,24}((\\-)?[a-z]{1,16})?)(\\.[a-z]{1,16}(\\.[a-z]{1,16}(\\.[a-z]{1,16})?)?)?)?_(m|w)$";
final String string = "2012.11.09_mary.a_san.luis.obispo_w\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}