const regex = /^(\d{4}\d{2}\d{2} \d{2}:\d{2}:\d{2}\.\d{3})\s{1}-Fatal\s{1}(.*?)(-\s{1})*proce:\s{1}(.*?)\s{1}-\s{1}pid\s{1}(\d{1,10})!!!$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4}\\d{2}\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d{3})\\s{1}-Fatal\\s{1}(.*?)(-\\s{1})*proce:\\s{1}(.*?)\\s{1}-\\s{1}pid\\s{1}(\\d{1,10})!!!$', '')
const str = `20160803 14:34:49.748 -Fatal oomtotal-vm:862604kB, anon-r:179196kB, file-r:31604kBproce: qtbrowser - pid 2206!!!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}