re = /({matrix}.*? \\)( .*?(?={matrix}))/m
str = 'matrix \\dfrac{ \\left( \\sqrt{ \\left(\\begin{matrix} 5 \\\\ \\left(\\begin{matrix} 66 \\ 11 \\end{matrix}\\right) \\ \\end{matrix}\\right) \\phantom{\\tiny{!}}} , \\sqrt[ 6 ]{ 66 \\phantom{\\tiny{!}}} \\right) }{ 6 } 5 \\dfrac{ 22 }{ 5 }'
subst = '$1\\\\$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result