#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^)(?=(\d{3})+(?=\.|$))"
Local $sString = "999999999" & @CRLF & _
"33333.25" & @CRLF & _
"222.32" & @CRLF & _
"4444"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)