const regex = /(?!^)(?=(\d{3})+(?=\.|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)(?=(\\d{3})+(?=\\.|$))', 'gm')
const str = `999999999
33333.25
222.32
4444`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);