$re = '/(?!^)(?=(\d{3})+(?=\.|$))/m';
$str = '999999999
33333.25
222.32
4444';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;