re = /(?!^)(?=(\d{3})+(?=\.|$))/m
str = '999999999
33333.25
222.32
4444'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result