import Foundation
let pattern = #"\..*$(*SKIP)(*F)|(?!^)(?=(?:\d{3})+(?=\.|$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
999999999
33333.25
222.32
4444
0.12345678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)