# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-z0-9\-._]/_/gi;t' <<< "_;<!--Invalid--!\"s\"' null"