package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.*\(\d{4}\)\.\s)([^.]*\.)(?: .*)`)
var str = `Parikka, J. (2010). Insect Media: An Archaeology of Animals and Technology. Minneapolis: Univ Of Minnesota Press.
Sanders, E. B.-N., Brandt, E., & Binder, T. (2010). A framework for organizing the tools and techniques of participatory design. In Proceedings of the 11th biennial participatory design conference (pp. 195–198). ACM. Retrieved from http://dl.acm.org/citation.cfm?id=1900476
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}