#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$"
Local $sString = "1.160.10.240" & @CRLF & _
"192.001.32.47" & @CRLF & _
"1.2.3." & @CRLF & _
"1.2.3" & @CRLF & _
"0.00.10.255" & @CRLF & _
"1.2.$.4" & @CRLF & _
"255.160.0.34" & @CRLF & _
".1.1.1" & @CRLF & _
"1..1.1.1" & @CRLF & _
"1.1.1.-0" & @CRLF & _
".1.1.+1" & @CRLF & _
"1 1 1 1" & @CRLF & _
"1" & @CRLF & _
"10.300.4.0" & @CRLF & _
"10.4F.10.99" & @CRLF & _
"fruit loops" & @CRLF & _
"1.2.3.4.5" & @CRLF & _
"0.0.0.0" & @CRLF & _
"0.0 0.0." & @CRLF & _
"1.23..4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")