use strict;
my $str = '1.160.10.240
192.001.32.47
1.2.3.
1.2.3
0.00.10.255
1.2.$.4
255.160.0.34
.1.1.1
1..1.1.1
1.1.1.-0
.1.1.+1
1 1 1 1
1
10.300.4.0
10.4F.10.99
fruit loops
1.2.3.4.5
0.0.0.0
0.0 0.0.
1.23..4';
my $regex = qr/^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}