#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\\([a-z]*)@(?(?<=[a-z]@)[a-z]*$|[a-z]+$)"
Local $sString = "\@" & @CRLF & _
"x@" & @CRLF & _
"x@x" & @CRLF & _
"@x" & @CRLF & _
"\xx" & @CRLF & _
"\@xxx" & @CRLF & _
"\xxx@" & @CRLF & _
"\x@x" & @CRLF & _
"\@x" & @CRLF & _
"\x@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")