re = /\\([a-z]*)@(?(?<=[a-z]@)[a-z]*$|[a-z]+$)/im
str = '\\@
x@
x@x
@x
\\xx
\\@xxx
\\xxx@
\\x@x
\\@x
\\x@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end