import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z0-9]{2,}).*(\\1)$";
final String string = "123123123123\n"
+ "daddaddaddad\n"
+ "sadsadasad\n"
+ "sadsadsad\n"
+ "121212121\n"
+ "sasasasasas\n"
+ "sdsdsdsds\n"
+ "dsdsdsdsd\n"
+ "ffffffff\n"
+ "blahblah\n"
+ "ioiooioioioi\n"
+ "popopopopop\n\n\n"
+ "Hi I dont think this is a spam.\n"
+ "II loooovve this. It's awesooooommeee!";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}