$re = '/\b(((copyright)\s)?)((©|\(c\))?[^(\(|\;|\{)])/i';
$str = 'Copyright ©
copyright ©
copyright (c)
Copyright (C)
copyright (C)
Copyright (c)
Copyright ©
copyright ©
copyright
(c)
function (c);
(C) {
(c);
function (c){
(C){
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);