re = /\b(((copyright)\s)?)((©|\(c\))?[^(\(|\;|\{)])/i
str = 'Copyright ©
copyright ©
copyright (c)
Copyright (C)
copyright (C)
Copyright (c)
Copyright ©
copyright ©
copyright
(c)
function (c);
(C) {
(c);
function (c){
(C){
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end