# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(")?(.*?)\1\s*(?:,|$)/($2)\n/gm;t' <<< "name,age,booktitle
John,,Hello World
Mary,3,\"\"Alas, What Can I do?\"\"
Joseph,5,\"Waiting, waiting, waiting\"
\"Donaldson Jones\" , six, \"Hello, friend!\""