const regex = /\s*(")?(.*?)\1\s*(?:,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(")?(.*?)\\1\\s*(?:,|$)', 'gm')
const str = `name,age,booktitle
John,,Hello World
Mary,3,""Alas, What Can I do?""
Joseph,5,"Waiting, waiting, waiting"
"Donaldson Jones" , six, "Hello, friend!"`;
const subst = `($2)\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);