# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*(\")?(.*?)\1\s*(?:,|$)"
test_str = ("name,age,booktitle\n"
"John,,Hello World\n"
"Mary,3,\"\"Alas, What Can I do?\"\"\n"
"Joseph,5,\"Waiting, waiting, waiting\"\n"
"\"Donaldson Jones\" , six, \"Hello, friend!\"")
subst = "($2)\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.