#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(0|\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}"
Local $sString = "0682928919" & @CRLF & _
"0501468879" & @CRLF & _
"0715448664" & @CRLF & _
"01656565656656" & @CRLF & _
"03 02 021 02" & @CRLF & _
"+33682928919" & @CRLF & _
"06.82.92.89.19" & @CRLF & _
"06 82 92 89 19" & @CRLF & _
"+336.82.92.89.19" & @CRLF & _
"+33 682928919"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")