$re = '/\<!ELEMENT\s+\w+\s+\(\W*(\w+)\W*\)/';
$str = '<!ELEMENT DealNumber (#PCDATA) >
<!ELEMENT DealParties (DealParty+)>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);