#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<<(?>(?>[^\\>]*)(?>>(?!>))?)*+\\(?>(?>[^>]*)(?>>(?!>))?)++>>"
Local $sString = "Account number: <<@Account.AccountNumber>>" & @CRLF & _
"<<@Am\hich\af1\dbch\af31505\loch\f1 ount>>" & @CRLF & _
"<<@Amount>>" & @CRLF & _
"<<Where: Phrase =\ @Value>>\<<hi>>\hi<<hi>> " & @CRLF & _
"<<\hich\af1\dbch\af31505\loch\f1 @Amount>>" & @CRLF & _
"<<@Amount\hich\af1\dbch\af31505\loch\f1 >>" & @CRLF & _
"<<Where: Column > Value>>" & @CRLF & _
"<<Where: Column\hich\af1\dbch\af31505\loch\f1 > Value>>" & @CRLF & _
"<<Where: Column > \hich\af1\dbch\af31505\loch\f1 Value>>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")