$re = '/href="https?:\/\/youtu.be\/(.*?)"/m';
$str = '<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>
<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>
<a href="https://youtu.be/z7Pq2N1aFM8">Le loup et les trois soeurs</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);