re = /(?<=Location:\s\<\/b\>\s)(.+?)(?=\<br\>)/
str = '<div class="FindBoxTopL fl_left">
<b>Salary: </b> $10.00 <br>
<b>Location: </b> Wisconsin Madison<br>
<b>Country:</b>United States<br>
<b>Contract Type: </b>Part Time<br><b>Closing Date: </b>August 15, 2014<br>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end