using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[pP].*[uUÜü@].*[bB].*[iIïÏ1|lL].*[|iIïÏ1lL].*[cC].*[|iIïÏ1lL].*[dD].*[aA4äÄ@Ã].*[dD])";
string input = @"publicidad";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}