#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([^a]|a+[^ab]|a+b[ab]*[^abc])*[ab]*$"
Local $sString = "a" & @CRLF & _
"ab" & @CRLF & _
"abc" & @CRLF & _
"abcd" & @CRLF & _
"abcab" & @CRLF & _
"b" & @CRLF & _
"ac" & @CRLF & _
"bc" & @CRLF & _
"ha" & @CRLF & _
"hab" & @CRLF & _
"habc" & @CRLF & _
"habcd" & @CRLF & _
"habcab" & @CRLF & _
"haab" & @CRLF & _
"haabc" & @CRLF & _
"haabcd" & @CRLF & _
"haba" & @CRLF & _
"habab" & @CRLF & _
"hababc" & @CRLF & _
"hababcd" & @CRLF & _
"ababd" & @CRLF & _
"abbd" & @CRLF & _
"aabbd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")