using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^a]|a+[^ab]|a+b[ab]*[^abc])*[ab]*$";
string input = @"a
ab
abc
abcd
abcab
b
ac
bc
ha
hab
habc
habcd
habcab
haab
haabc
haabcd
haba
habab
hababc
hababcd
ababd
abbd
aabbd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}