package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([^a]|a+[^ab]|a+b[ab]*[^abc])*[ab]*$`)
var str = `a
ab
abc
abcd
abcab
b
ac
bc
ha
hab
habc
habcd
habcab
haab
haabc
haabcd
haba
habab
hababc
hababcd
ababd
abbd
aabbd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}