re = /^([^a]|a+[^ab]|a+b[ab]*[^abc])*[ab]*$/im
str = 'a
ab
abc
abcd
abcab
b
ac
bc
ha
hab
habc
habcd
habcab
haab
haabc
haabcd
haba
habab
hababc
hababcd
ababd
abbd
aabbd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end