$re = '/(?:calc\(|(?!^)\G)[^)+-]*\K[-+]/';
$str = '-webkit-calc(50%+4px/2+32px-32px*23%)';
$subst = " $0 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;