$re = '/(?:\s*->\s*[\w.]+(\((?>\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\'|"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|[^"\'()]++|(?1))*\)))+\s*\z/';
$str = 'o.start_time = obj.s;
o.repair_type -> obj.r;
o.limit -> obj.l;->god("(\'\\"\\"\')") ->fox(,\'->\')
->egg()->dog(,\'c\')
->cat(,\'b\')-> banana(,\'a"\\\'\\(\\)\\\'->"()(\') -> apple(,\'a\')';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);