re = /(?:((?(3)\s*|\R*)->\s*([\w.]*(\((?>'[^'\\]*(?:\\.[^'\\]*)*'|"[^"\\]*(?:\\.[^"\\]*)*"|[^"'()]++|(?3))*\)))))+\s*\z/
str = 'o.start_time = obj.s;
o.repair_type -> obj.r;
o.limit -> obj.l;
->god("(\'\\"\\"\')") ->fox(,\'->\')
->egg()->dog(,\'c\')
->cat(,\'b\')-> banana(,\'a"\\\'\\(\\)\\\'->"()(\') -> apple(,\'a\')'
# Print the match result
str.match(re) do |match|
puts match.to_s
end