$re = '/([\d.]+UAH)[\s\S]+(?=(4\*35))[\s\S]+\s(?(2)([\d.]+UAH))/im';
$str = '100.00UAH Znyattya gotivki v bankomati WWWW, SSDSD
4*35 12:11
Bal. 1111.52UAH
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);