#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{{showcase_small\("([^"]+)"\)}}"
Local $sString = "{{showcase_small("classy_box")}}"
Local $sSubst = "$showcase->classyBox("${1}")"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)