using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{showcase_small\(""([^""]+)""\)}}";
string substitution = @"$showcase->classyBox(""${1}"")";
string input = @"{{showcase_small(""classy_box"")}}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}