import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{showcase_small\\(\"([^\"]+)\"\\)\\}\\}";
final String string = "{{showcase_small(\"classy_box\")}}";
final String subst = "$showcase->classyBox(\"${1}\")";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}