$re = '/^(?=.*\bjack\b)(?=.*\bjames\b).*$/';
$str = 'hi jack here is james
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);