re = /(?:Data|Field)(?!\h*$).+$/m
str = 'Data
Data
Datatest1
Data test
Data 867$33@!.//()7
Field somthing
Field '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end