import re
regex = re.compile(r"(\D)\.")
test_str = ("FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41\n"
"Hello.World")
subst = "\\1 "
result = regex.sub(subst, test_str)
if result:
print(result)