# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\D)\.(?=\D)/ /g;t' <<< "FRAME WINDOW MASTER. 160.055-44.9 ADULT Z68.41
Hello.World"