#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\-a-z]+$"
Local $sString = "pink-floyd" & @CRLF & _
"INVALID" & @CRLF & _
"tiësto-NOPE" & @CRLF & _
"deadmaus" & @CRLF & _
"deadbeef" & @CRLF & _
"0xDEADBEEF" & @CRLF & _
"none-of-these-&&&" & @CRLF & _
"or-these-???" & @CRLF & _
"just-lowercase-and-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")