$re = '/(?=[0-9,]+$)((?<=,|^)[0-9]{1,2})(?=,|$)/';
$str = '31,5,46,7,86';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);