package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`id_(\w+)`)
var str = `http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}