import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(mini|super|hiper)?mercado$";
final String string = "____________Sim_\n"
+ "mercado\n"
+ "minimercado\n"
+ "supermercado\n"
+ "hipermercado\n\n"
+ "____________Não_\n"
+ "mercador\n"
+ "mini\n"
+ "valtermercado";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}