re = /(?:[0-9#*]️⃣|[☝✊-✍🎅🏂🏇👂👃👆-👐👦👧👫-👭👲👴-👶👸👼💃💅💏💑💪🕴🕺🖐🖕🖖🙌🙏🛀🛌🤌🤏🤘-🤟🤰-🤴🤶🥷🦵🦶🦻🧒🧓🧕🫃-🫅🫰🫲-🫸][🏻-🏿]?|⛓(?:️💥)?|[⛹🏋🏌🕵](?:️[♀♂]️|[🏻-🏿](?:[♀♂]️)?)?|❤(?:️[🔥🩹])?|🇦[🇨-🇬🇮🇱🇲🇴🇶-🇺🇼🇽🇿]|🇧[🇦🇧🇩-🇯🇱-🇴🇶-🇹🇻🇼🇾🇿]|🇨[🇦🇨🇩🇫-🇮🇰-🇵🇷🇺-🇿]|🇩[🇪🇬🇯🇰🇲🇴🇿]|🇪[🇦🇨🇪🇬🇭🇷-🇺]|🇫[🇮-🇰🇲🇴🇷]|🇬[🇦🇧🇩-🇮🇱-🇳🇵-🇺🇼🇾]|🇭[🇰🇲🇳🇷🇹🇺]|🇮[🇨-🇪🇱-🇴🇶-🇹]|🇯[🇪🇲🇴🇵]|🇰[🇪🇬-🇮🇲🇳🇵🇷🇼🇾🇿]|🇱[🇦-🇨🇮🇰🇷-🇻🇾]|🇲[🇦🇨-🇭🇰-🇿]|🇳[🇦🇨🇪-🇬🇮🇱🇴🇵🇷🇺🇿]|🇴🇲|🇵[🇦🇪-🇭🇰-🇳🇷-🇹🇼🇾]|🇶🇦|🇷[🇪🇴🇸🇺🇼]|🇸[🇦-🇪🇬-🇴🇷-🇹🇻🇽-🇿]|🇹[🇦🇨🇩🇫-🇭🇯-🇴🇷🇹🇻🇼🇿]|🇺[🇦🇬🇲🇳🇸🇾🇿]|🇻[🇦🇨🇪🇬🇮🇳🇺]|🇼[🇫🇸]|🇽🇰|🇾[🇪🇹]|🇿[🇦🇲🇼]|🍄(?:🟫)?|🍋(?:🟩)?|[🏃🚶🧎](?:(?:[♀♂]️(?:➡️)?|➡️)|[🏻-🏿](?:(?:[♀♂]️(?:➡️)?|➡️))?)?|[🏄🏊👮👰👱👳👷💁💂💆💇🙅-🙇🙋🙍🙎🚣🚴🚵🤦🤵🤷-🤹🤽🤾🦸🦹🧍🧏🧔🧖-🧝](?:[♀♂]️|[🏻-🏿](?:[♀♂]️)?)?|🏳(?:️(?:⚧️|🌈))?|🏴(?:☠️|(?:(?:|))?)?|🐈(?:⬛)?|🐕(?:🦺)?|🐦(?:[⬛🔥])?|🐻(?:❄️)?|👁(?:️🗨️)?|👨(?:(?:[⚕⚖✈]️|❤️(?:💋)?👨|👦(?:👦)?|👧(?:[👦👧])?|[👨👩](?:👦(?:👦)?|👧(?:[👦👧])?)|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳])|🏻(?:(?:[⚕⚖✈]️|❤️(?:💋)?👨[🏻-🏿]|🤝👨[🏼-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏼(?:(?:[⚕⚖✈]️|❤️(?:💋)?👨[🏻-🏿]|🤝👨[🏻🏽-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏽(?:(?:[⚕⚖✈]️|❤️(?:💋)?👨[🏻-🏿]|🤝👨[🏻🏼🏾🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏾(?:(?:[⚕⚖✈]️|❤️(?:💋)?👨[🏻-🏿]|🤝👨[🏻-🏽🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏿(?:(?:[⚕⚖✈]️|❤️(?:💋)?👨[🏻-🏿]|🤝👨[🏻-🏾]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?)?|👩(?:(?:[⚕⚖✈]️|❤️(?:[👨👩]|💋[👨👩])|👦(?:👦)?|👧(?:[👦👧])?|👩(?:👦(?:👦)?|👧(?:[👦👧])?)|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳])|🏻(?:(?:[⚕⚖✈]️|❤️(?:💋)?[👨👩][🏻-🏿]|🤝[👨👩][🏼-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏼(?:(?:[⚕⚖✈]️|❤️(?:💋)?[👨👩][🏻-🏿]|🤝[👨👩][🏻🏽-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏽(?:(?:[⚕⚖✈]️|❤️(?:💋)?[👨👩][🏻-🏿]|🤝[👨👩][🏻🏼🏾🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏾(?:(?:[⚕⚖✈]️|❤️(?:💋)?[👨👩][🏻-🏿]|🤝[👨👩][🏻-🏽🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏿(?:(?:[⚕⚖✈]️|❤️(?:💋)?[👨👩][🏻-🏿]|🤝[👨👩][🏻-🏾]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?)?|[👯🤼🧞🧟](?:[♀♂]️)?|😮(?:💨)?|😵(?:💫)?|😶(?:🌫️)?|🙂(?:[↔↕]️)?|🧑(?:(?:[⚕⚖✈]️|🤝🧑|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎄🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]|(?:🧑)?🧒(?:🧒)?)|🏻(?:(?:[⚕⚖✈]️|❤️(?:💋)?🧑[🏼-🏿]|🤝🧑[🏻-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎄🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏼(?:(?:[⚕⚖✈]️|❤️(?:💋)?🧑[🏻🏽-🏿]|🤝🧑[🏻-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎄🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏽(?:(?:[⚕⚖✈]️|❤️(?:💋)?🧑[🏻🏼🏾🏿]|🤝🧑[🏻-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎄🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏾(?:(?:[⚕⚖✈]️|❤️(?:💋)?🧑[🏻-🏽🏿]|🤝🧑[🏻-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎄🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?|🏿(?:(?:[⚕⚖✈]️|❤️(?:💋)?🧑[🏻-🏾]|🤝🧑[🏻-🏿]|[🦯🦼🦽](?:➡️)?|[🌾🍳🍼🎄🎓🎤🎨🏫🏭💻💼🔧🔬🚀🚒🦰-🦳]))?)?|[©®‼⁉™ℹ↔-↙↩↪⌚⌛⌨⏏⏩-⏳⏸-⏺Ⓜ▪▫▶◀◻-◾☀-☄☎☑☔☕☘☠☢☣☦☪☮☯☸-☺♀♂♈-♓♟♠♣♥♦♨♻♾♿⚒-⚗⚙⚛⚜⚠⚡⚧⚪⚫⚰⚱⚽⚾⛄⛅⛈⛎⛏⛑⛔⛩⛪⛰-⛵⛷⛸⛺⛽✂✅✈✉✏✒✔✖✝✡✨✳✴❄❇❌❎❓-❕❗❣➕-➗➡➰➿⤴⤵⬅-⬇⬛⬜⭐⭕〰〽㊗㊙🀄🃏🅰🅱🅾🅿🆎🆑-🆚🈁🈂🈚🈯🈲-🈺🉐🉑🌀-🌡🌤-🍃🍅-🍊🍌-🎄🎆-🎓🎖🎗🎙-🎛🎞-🏁🏅🏆🏈🏉🏍-🏰🏵🏷-🐇🐉-🐔🐖-🐥🐧-🐺🐼-👀👄👅👑-👥👪👹-👻👽-💀💄💈-💎💐💒-💩💫-📽📿-🔽🕉-🕎🕐-🕧🕯🕰🕳🕶-🕹🖇🖊-🖍🖤🖥🖨🖱🖲🖼🗂-🗄🗑-🗓🗜-🗞🗡🗣🗨🗯🗳🗺-😭😯-😴😷-🙁🙃🙄🙈-🙊🚀-🚢🚤-🚳🚷-🚿🛁-🛅🛋🛍-🛒🛕-🛗🛜-🛥🛩🛫🛬🛰🛳-🛼🟠-🟫🟰🤍🤎🤐-🤗🤠-🤥🤧-🤯🤺🤿-🥅🥇-🥶🥸-🦴🦷🦺🦼-🧌🧐🧠-🧿🩰-🩼🪀-🪈🪐-🪽🪿-🫂🫎-🫛🫠-🫨]|🫱(?:🏻(?:🫲[🏼-🏿])?|🏼(?:🫲[🏻🏽-🏿])?|🏽(?:🫲[🏻🏼🏾🏿])?|🏾(?:🫲[🏻-🏽🏿])?|🏿(?:🫲[🏻-🏾])?)?)+/m
str = '😎🤘🏾
Wow Amazing!!!
I am loving it😍😘
🤘🏾 Rocking
Not Recommended 😒😼
😾'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result